Degraded Performance: Investigating
Major incident
Hive CPQ application
Hive CPQ API
2026-07-10 09:45 UTC
· 1 hour, 27 minutes
Updates
Resolved
July 10, 2026 · 11:11 UTC
The issue has been resolved. Our team does continue to monitor the situation.
Monitoring
July 10, 2026 · 09:59 UTC
The performance of the Hive CPQ application has returned to normal. We are currently monitoring the situation.
Investigating
July 10, 2026 · 09:45 UTC
We’re currently experiencing elevated response times across parts of the Hive CPQ platform. Our engineering team is investigating the issue.
You may notice slower page loads or occasional errors when configuring products or opening projects.
The Hive CPQ team
← Back
Hive CPQ Status Page