App performance degradation
Major incident
HiveCPQ application
HiveConnect
HiveCPQ API
2026-06-29 13:28 UTC
· 20 minutes
Updates
Resolved
June 29, 2026 · 13:44 UTC
We have identified the root cause of the issue and it has been resolved.
Issue
June 29, 2026 · 13:28 UTC
We are aware of an ongoing issue causing the application to run slower than normal. Our team is actively investigating the root cause. There is no confirmed cause or fix yet.
← Back
Hive CPQ Status Page