Investigating - Degraded performance
Major incident
HiveCPQ application
2026-05-15 12:19 UTC
· 53 minutes
Updates
Resolved
May 15, 2026 · 13:01 UTC
Resolved — Platform stability
The issue causing intermittent instability on the platform has
been identified and resolved. All services are operating normally
again.
We are continuing to monitor closely over the coming hours to
confirm stable behaviour.
Thank you for your patience.
Investigating
May 15, 2026 · 12:19 UTC
We’re currently investigating reports of slower-than-usual performance in the Hive CPQ application. Some users may experience delays when loading pages or performing actions.
The application remains available and no data is affected. Our team is actively working on a resolution.
We’ll share an update as soon as we have more information. Thank you for your patience.
← Back
HiveCPQ Status