App Performance Issue – Investigation in Progress
Major incident
HiveCPQ application
HiveConnect
HiveCPQ API
2025-11-06 10:15 UTC
· 12 minutes
Updates
Resolved
November 6, 2025 · 10:27 UTC
The earlier performance issue causing slow response times in the Hive CPQ app has been fully resolved.
Our team identified and addressed the root cause, and the application is now performing normally.
Kind regards,
Stijn
Issue
November 6, 2025 · 10:15 UTC
Some customers are currently experiencing slow performance in the Hive CPQ app.
Our team is actively investigating the issue and working to resolve it as quickly as possible.
We’ll share another update as soon as we have more information.
← Back
HiveCPQ Status