Login Issues
Major incident
HiveCPQ application
2025-10-20 06:43 UTC
· 2 hours, 10 minutes
Updates
Resolved
October 20, 2025 · 08:46 UTC
Users can login again normally via the “Continue via last login” screen.
If the infinite spinner would still appear in this screen when trying to login, use the “Use another account” link on that screen & manually provide your email & password again. This can be caused by browser caching not loading our fix for this problem.
Investigating
October 20, 2025 · 06:43 UTC
We are currently investigating an issue causing login attempts to fail or take longer than expected. This may affect a subset of users trying to access the Hive CPQ application. Our engineering team is actively investigating the cause and working to restore normal login functionality as quickly as possible.
← Back
HiveCPQ Status